[Poj 1426] Find The Multiple BFS

本文介绍了一种使用BFS算法解决寻找特定整数倍数的问题,该倍数仅包含0和1作为其十进制表示的解决方案。详细解释了输入输出格式、算法实现和示例输入输出。

摘要生成于 C知道 ,由 DeepSeek-R1 满血版支持, 前往体验 >

Find The Multiple
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 24596 Accepted: 10128 Special Judge

Description
Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.

Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.

Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.

Sample Input

2
6
19
0

Sample Output

10
100100100100100100
111111111111111111’

用BFS来搜索满足条件的数,注意必须使用long long

#include<iostream>
#include<stdio.h>
#include<queue>
using namespace std;
int x;
long long ans;
int flag;
struct node{
    long long y;
    int step;
    node(long long yy,int st)
    {
        y=yy;
        step=st;
    }node(){}
};
queue<node> q;
void bfs()
{
    while(!q.empty()) q.pop();
    q.push(node(0,1));
    q.push(node(1,1));
    if(x==1) flag=1;
    if(x==1) ans=1;
    while(!q.empty())
    {
        if(flag) break;
        node now=q.front();
        //cout<<now.y<<endl;
        q.pop();
        for(int k=0;k<=1;k++)
        {
        //cout<<now.step<<endl;
            long long mx=0;
            if(k==1) mx++;
            if(k==1)
            for(int i=1;i<=now.step;i++)   mx*=(long long)10;
            //cout<<"   "<<mx<<endl;
            mx+=now.y;
            if(mx!=0&&mx%x==0)
            {
                ans=mx;
                flag=1;
            }
            q.push(node(mx,now.step+1));
        }   
    }   
}
int main()
{
    while(scanf("%d",&x))
    {
        flag=0;
        if(x==0) return 0;

        bfs();
        printf("%lld\n",ans);
    }


}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值